Skip to main content
← All vulnerabilities
CVE-2020-36761

Top 10 <= 2.9.4 - Cross-Site Request Forgery Bypass

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.9.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Top 10 plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.10.4. This is due to missing or incorrect nonce validation on the tptn_export_tables() function. This makes it possible for unauthenticated attackers to generate an export of the top 10 table via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • ajay WebberZone Top 10 — Popular Posts

    fixed in 2.9.5

References 9

wordfence.com

blog.nintechnet.com

plugins.trac.wordpress.org