Skip to main content
← All vulnerabilities
CVE-2020-36282GHSA-V525-C3G5-CG9P

JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.0, 1.15.2
None on Exploit-DB, Metasploit or GitHub

Summary

JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • com.rabbitmq.jms:rabbitmq-jmsMaven

    From 2.0 · fixed in 2.2.0

  • com.rabbitmq.jms:rabbitmq-jmsMaven

    From 1.0 · fixed in 1.15.2

References 4

medium.com

GitHub · rabbitmq/rabbitmq-jms-client