CVE-2020-35239GHSA-9PGX-PF36-W46R
A vulnerability exists in CakePHP versions 4.0.x through 4.1.3.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.0.10, 4.1.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. The CsrfProtectionMiddleware component allows method override parameters to bypass CSRF checks by changing the HTTP request method to an arbitrary string that is not in the list of request methods that CakePHP checks. Additionally, the route middleware does not verify that this overriden method (which can be an arbitrary string) is actually an HTTP method.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- cakephp/cakephpPackagist
From 4.0.0 · fixed in 4.0.10
- cakephp/cakephpPackagist
From 4.1.0 · fixed in 4.1.4