Skip to main content
← All vulnerabilities
CVE-2020-35128GHSA-98J2-3JV7-274M

Mautic before 3.2.4 is affected by stored XSS.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.4, 2.16.5
None on Exploit-DB, Metasploit or GitHub

Summary

Mautic before 3.2.4 is affected by stored XSS. An attacker with permission to manage companies, an application feature, could attack other users, including administrators. For example, by loading an externally crafted JavaScript file, an attacker could eventually perform actions as the target user. These actions include changing the user passwords, altering user or email addresses, or adding a new administrator to the system.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • mautic/corePackagist

    From 3.2.0 · fixed in 3.2.4

  • mautic/corePackagist

    From 2.0.0 · fixed in 2.16.5

References 3

forum.mautic.org

labs.bishopfox.com