CVE-2020-27350
apt integer wraparound
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.2.32ubuntu0.2, 1.6.12ubuntu0.2, 2.0.2ubuntu0.2, 2.1.10ubuntu0.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
APT had several integer overflows and underflows while parsing .deb packages, aka GHSL-2020-168 GHSL-2020-169, in files apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc. This issue affects: apt 1.2.32ubuntu0 versions prior to 1.2.32ubuntu0.2; 1.6.12ubuntu0 versions prior to 1.6.12ubuntu0.2; 2.0.2ubuntu0 versions prior to 2.0.2ubuntu0.2; 2.1.10ubuntu0 versions prior to 2.1.10ubuntu0.1;
Timeline
- CVE published
- Record last updated
Affected versions
- Canonical apt
From 1.2.32ubuntu0 · fixed in 1.2.32ubuntu0.2; From 1.6.12ubuntu0 · fixed in 1.6.12ubuntu0.2; From 2.0.2ubuntu0 · fixed in 2.0.2ubuntu0.2; From 2.1.10ubuntu0 · fixed in 2.1.10ubuntu0.1