Skip to main content
← All vulnerabilities
CVE-2020-26285

Widget instances allows a hacker to inject an executable file on the server on OpenMage

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 19.4.10, 20.0.5
None on Exploit-DB, Metasploit or GitHub

Summary

OpenMage is a community-driven alternative to Magento CE. In OpenMage before versions 19.4.10 and 20.0.5, there is a vulnerability which enables remote code execution. In affected versions an administrator with permission to import/export data and to create widget instances was able to inject an executable file on the server. The latest OpenMage Versions up from 19.4.9 and 20.0.5 have this Issue solved

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • OpenMage magento-lts

    fixed in 19.4.10; From 20.0.0 · fixed in 20.0.5

References 3

GitHub · OpenMage/magento-lts