Skip to main content
← All vulnerabilities
CVE-2020-26223GHSA-M2JR-HMC3-QMPR

Authorization bypass in Spree

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.13, 4.0.5, 4.1.12
None on Exploit-DB, Metasploit or GitHub

Summary

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • spree spree

    From 3.7.0 · fixed in 3.7.13; From 4.0.0 · fixed in 4.0.5; From 4.1.0 · fixed in 4.1.12

  • spree_apiRubyGems

    From 3.7.0 · fixed in 3.7.13

  • spree_apiRubyGems

    From 4.0.0 · fixed in 4.0.5

  • spree_apiRubyGems

    From 4.1.0 · fixed in 4.1.12

References 3

GitHub · spree/spree

guides.spreecommerce.org