Skip to main content
← All vulnerabilities
CVE-2020-26217GHSA-MW36-7C6C-Q4Q2BIT-ACTIVEMQ-2020-26217

Remote Code Execution in XStream

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.4.14, 5.15.14, 1.4.14-java7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • x-stream xstream

    fixed in 1.4.14

  • activemqBitnami

    fixed in 5.15.14; From 5.16.0 · through 5.16.0

  • com.thoughtworks.xstream:xstreamMaven

    fixed in 1.4.14-java7

References 15

GitHub · x-stream/xstream

x-stream.github.io

lists.debian.org

debian.org

lists.apache.org

oracle.com

security.netapp.com