CVE-2020-25814GHSA-4VR7-M8P8-434HBIT-MEDIAWIKI-2020-25814
In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.31.9, 1.34.3, 1.35.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- mediawiki/corePackagist
From 1.31.0 · fixed in 1.31.9
- mediawiki/corePackagist
From 1.32.0 · fixed in 1.34.3
- mediawiki/corePackagist
From 1.35.0-rc.0 · fixed in 1.35.0