Skip to main content
← All vulnerabilities
CVE-2020-25701GHSA-C9HQ-G4Q8-W893BIT-MOODLE-2020-25701

If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would e

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15
None on Exploit-DB, Metasploit or GitHub

Summary

If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a moodle

    Fixed in 3.9.3, Fixed in 3.8.6, Fixed in 3.7.9, Fixed in 3.5.15, Fixed in 3.10

  • moodle/moodlePackagist

    From 3.9.0 · fixed in 3.9.3

  • moodle/moodlePackagist

    From 3.8.0 · fixed in 3.8.6

  • moodle/moodlePackagist

    From 3.7.0 · fixed in 3.7.9

  • moodle/moodlePackagist

    From 3.5 · fixed in 3.5.15

References 4

bugzilla.redhat.com

moodle.org

lists.fedoraproject.org