CVE-2020-25698GHSA-VXHX-GMHM-623CBIT-MOODLE-2020-25698
Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a moodle
Fixed in 3.9.3, Fixed in 3.8.6, Fixed in 3.7.9, Fixed in 3.5.15, Fixed in 3.10
- moodle/moodlePackagist
From 3.9.0 · fixed in 3.9.3
- moodle/moodlePackagist
From 3.8.0 · fixed in 3.8.6
- moodle/moodlePackagist
From 3.7.0 · fixed in 3.7.9
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.15