Skip to main content
← All vulnerabilities
CVE-2020-25629GHSA-F5R8-7H4F-JR9XBIT-MOODLE-2020-25629

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.9.2, 3.8.5, 3.7.8, 3.5.14
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Moodle

    3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13

  • moodle/moodlePackagist

    From 3.9 · fixed in 3.9.2

  • moodle/moodlePackagist

    From 3.8 · fixed in 3.8.5

  • moodle/moodlePackagist

    From 3.7 · fixed in 3.7.8

  • moodle/moodlePackagist

    From 3.5 · fixed in 3.5.14

References 1

moodle.org