Skip to main content
← All vulnerabilities
CVE-2020-25628GHSA-5X33-H32W-6VR2BIT-MOODLE-2020-25628

The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.9.2, 3.8.5, 3.7.8, 3.5.14
None on Exploit-DB, Metasploit or GitHub

Summary

The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Moodle

    3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13

  • moodle/moodlePackagist

    From 3.9.0 · fixed in 3.9.2

  • moodle/moodlePackagist

    From 3.8.0 · fixed in 3.8.5

  • moodle/moodlePackagist

    From 3.7.0 · fixed in 3.7.8

  • moodle/moodlePackagist

    From 3.5 · fixed in 3.5.14

References 2

git.moodle.org

moodle.org