Skip to main content
← All vulnerabilities
CVE-2020-24553GO-2021-0226BIT-GOLANG-2020-24553

Go before 1.14.8 and 1.15.x before 1.15.1 allows XSS because text/html is the default for CGI/FCGI handlers that lack a Content-Type header.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.14.8, 1.15.1
None on Exploit-DB, Metasploit or GitHub

Summary

Go before 1.14.8 and 1.15.x before 1.15.1 allows XSS because text/html is the default for CGI/FCGI handlers that lack a Content-Type header.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • stdlibGo

    fixed in 1.14.8; From 1.15.0-0 · fixed in 1.15.1

References 10

seclists.org

lists.fedoraproject.org

lists.opensuse.org

oracle.com

groups.google.com

packetstormsecurity.com

security.netapp.com

redteam-pentesting.de