CVE-2020-24403GHSA-39RW-4M66-82GFBIT-MAGENTO-2020-24403
Incorrect permissions could lead to unauthorized modification of inventory source data via REST API
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.6, 2.4.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect user permissions vulnerability within the Inventory component. This vulnerability could be abused by authenticated users with Inventory and Source permissions to make unauthorized changes to inventory source data via the REST API.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.0; through 2.3.5p1
- magento/community-editionPackagist
fixed in 2.3.6
- magento/community-editionPackagist
From 2.4.0 · fixed in 2.4.1
- magento/project-community-editionPackagist
through 2.0.2