CVE-2020-24402GHSA-HVF5-4JR9-FGHHBIT-MAGENTO-2020-24402
Incorrect permissions in the Integrations component could lead to unauthorized deletion of customer details via REST API
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.6, 2.4.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability in the Integrations component. This vulnerability could be abused by authenticated users with permissions to the Resource Access API to delete customer details via the REST API without authorization.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.0; through 2.3.5p1
- magento/community-editionPackagist
fixed in 2.3.6
- magento/community-editionPackagist
From 2.4.0 · fixed in 2.4.1
- magento/project-community-editionPackagist
through 2.0.2