Skip to main content
← All vulnerabilities
CVE-2020-24400GHSA-PF6W-3PFW-FXVWBIT-MAGENTO-2020-24400

SQL injection allows arbitrary read from database

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.6, 2.4.1
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information disclosure. This vulnerability could be exploited by an authenticated user with permissions to the product listing page to read data from the database.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.0; through 2.3.5

  • magento/community-editionPackagist

    fixed in 2.3.6

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.1

References 1

helpx.adobe.com