CVE-2020-2307GHSA-FH5W-P2J4-4P8X
Jenkins Kubernetes Plugin 1.27.3 and earlier allows low-privilege users to access possibly sensitive Jenkins controller environment variable
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.27.4, 1.26.5, 1.25.4.1, 1.21.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jenkins Kubernetes Plugin 1.27.3 and earlier allows low-privilege users to access possibly sensitive Jenkins controller environment variables.
Timeline
- CVE published
- Record last updated
Affected versions
- Jenkins project Jenkins Kubernetes Plugin
through 1.27.3
- org.csanchez.jenkins.plugins:kubernetesMaven
From 1.27.0 · fixed in 1.27.4
- org.csanchez.jenkins.plugins:kubernetesMaven
From 1.26.0 · fixed in 1.26.5
- org.csanchez.jenkins.plugins:kubernetesMaven
From 1.22.0 · fixed in 1.25.4.1
- org.csanchez.jenkins.plugins:kubernetesMaven
fixed in 1.21.6