Skip to main content
← All vulnerabilities
CVE-2020-2305GHSA-X58R-WXC3-7PQR

Jenkins Mercurial Plugin 2.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.12, 2.10.1, 2.9.1, 2.8.1
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins Mercurial Plugin 2.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins Mercurial Plugin

    through 2.11

  • org.jenkins-ci.plugins:mercurialMaven

    From 2.11 · fixed in 2.12

  • org.jenkins-ci.plugins:mercurialMaven

    From 2.10 · fixed in 2.10.1

  • org.jenkins-ci.plugins:mercurialMaven

    From 2.9 · fixed in 2.9.1

  • org.jenkins-ci.plugins:mercurialMaven

    fixed in 2.8.1

References 1

jenkins.io