Skip to main content
← All vulnerabilities
CVE-2020-2161GHSA-G8PG-QRVM-WGH2BIT-JENKINS-2020-2161

Jenkins 2.227 and earlier, LTS 2.204.5 and earlier does not properly escape node labels that are shown in the form validation for label expr

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.228
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins 2.227 and earlier, LTS 2.204.5 and earlier does not properly escape node labels that are shown in the form validation for label expressions on job configuration pages, resulting in a stored XSS vulnerability exploitable by users able to define node labels.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins

    through 2.227; through LTS 2.204.5

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.228

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.204.6 · fixed in 2.228

References 2

jenkins.io

openwall.com